5
Vote

log in errors on linux

description

I am experiencing problems with this application on Arch Linux (x86_64). I have double-checked the .config file to ensure that my username and password are correct, but I am unable to log in. I have pasted the results of "mono API.WindowsLive.SkyDrive.exe" and some relevant system information below.
 
 
$ mono API.WindowsLive.SkyDrive.exe
Load configuration
Load UI
Initializing
Log in
Start schedule
Could not log on, please check username and password.
Object reference not set to an instance of an object
Done press any key to continue
 
 
$ mono -V
Mono JIT compiler version 2.6.7 (tarball Sun Jul 25 19:50:39 CEST 2010)
Copyright (C) 2002-2010 Novell, Inc and Contributors. www.mono-project.com
TLS:           __thread
GC:            Included Boehm (with typed GC and Parallel Mark)
SIGSEGV:       altstack
Notifications: epoll
Architecture:  amd64
Disabled:      none

comments

voodoor wrote Aug 7, 2010 at 11:28 PM

Can you please try SkyDriveSync Beta 0.3.

I tested it on Open Suse with Mono 2.6.1 and it seems to be working fine.

Also note that there might be an issue running the application with accounts that do not end with @hotmail.com I am investigating that problem.

wrote Sep 16, 2010 at 2:51 PM

gexc wrote Sep 16, 2010 at 2:55 PM

I also have such an issue. My account ends with @msn.com though...

My OS is gentoo x86_64

mono -V
Mono JIT compiler version 2.6.7 (tarball Wed Sep 8 15:50:46 CST 2010)
Copyright (C) 2002-2010 Novell, Inc and Contributors. www.mono-project.com
    TLS:           __thread
    GC:            Included Boehm (with typed GC and Parallel Mark)
    SIGSEGV:       altstack
    Notifications: epoll
    Architecture:  amd64
    Disabled:      none

gonvaro wrote Oct 31, 2010 at 2:07 PM

Hi;

Something similar is happening to me, I have:
  • OpenSuse 11.3.
  • Newly installed mono full.
  • SkyDrive Synchronizer (SkyDrive Sync Beta 0.3)
I will show:

$ mono API.WindowsLive.SkyDrive.exe
Load configuration
Load UI
Initializing
Log in
Start schedule
Object reference not set to an instance of an object
Done press any key to continue

$ mono -V
Mono JIT compiler version 2.8 (tarball Tue Oct 5 20:43:49 UTC 2010)
Copyright (C) 2002-2010 Novell, Inc and Contributors. www.mono-project.com
TLS:           __thread
SIGSEGV:       altstack
Notifications: epoll
Architecture:  x86
Disabled:      none
Misc:          debugger softdebug 
LLVM:          yes(2.8svn-mono)
GC:            Included Boehm (with typed GC and Parallel Mark)

gonvaro wrote Oct 31, 2010 at 2:08 PM

Hi;

Something similar is happening to me, I have:
  • OpenSuse 11.3.
  • Newly installed mono full.
  • SkyDrive Synchronizer (SkyDrive Sync Beta 0.3)
I will show:

$ mono API.WindowsLive.SkyDrive.exe
Load configuration
Load UI
Initializing
Log in
Start schedule
Object reference not set to an instance of an object
Done press any key to continue

$ mono -V
Mono JIT compiler version 2.8 (tarball Tue Oct 5 20:43:49 UTC 2010)
Copyright (C) 2002-2010 Novell, Inc and Contributors. www.mono-project.com
TLS: __thread
SIGSEGV: altstack
Notifications: epoll
Architecture: x86
Disabled: none
Misc: debugger softdebug
LLVM: yes(2.8svn-mono)
GC: Included Boehm (with typed GC and Parallel Mark)

gonvaro wrote Feb 12, 2011 at 7:56 PM

Hi,
Download Beta 0.3

The Mono version is :
mono -V
Mono JIT compiler version 2.8.2 (tarball Tue Jan 4 18:36:17 UTC 2011)
Copyright (C) 2002-2010 Novell, Inc and Contributors. www.mono-project.com
    TLS:           __thread
    SIGSEGV:       altstack
    Notifications: epoll
    Architecture:  x86
    Disabled:      none
    Misc:          debugger softdebug 
    LLVM:          yes(2.8svn-mono)

GC: Included Boehm (with typed GC and Parallel Mark)

mono API.WindowsLive.SkyDrive.exe
Load configuration
Load UI
Initializing
Log in
Start schedule
Argument cannot be null.
Parameter name: requestUri
Done press any key to continue

gonvaro wrote Feb 12, 2011 at 8:04 PM

The different account to @ hotmail, apparently is not a cause of this error. I tried it with an @ hotmail account and it happens exactly the same:
mono API.WindowsLive.SkyDrive.exe
Load configuration
Load UI
Initializing
Start schedule
Log in
Argument cannot be null.
Parameter name: requestUri
Done press any key to continue

wrote May 27, 2011 at 11:15 PM

wrote Aug 8, 2011 at 3:57 PM

amontero wrote Aug 8, 2011 at 4:08 PM

Same here. Using included config file with a non-hotmail.com email address and triple-checked password.

Test environment info:

~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.04
Release: 11.04
Codename: natty

~$ uname -a
Linux homePC 2.6.38-10-generic #46-Ubuntu SMP Tue Jun 28 15:07:17 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

~$ mono -V
Mono JIT compiler version 2.6.7 (Debian 2.6.7-5ubuntu3)
Copyright (C) 2002-2010 Novell, Inc and Contributors. www.mono-project.com
TLS:           __thread
GC:            Included Boehm (with typed GC and Parallel Mark)
SIGSEGV:       altstack
Notifications: epoll
Architecture:  amd64
Disabled:      none
~$ mono API.WindowsLive.SkyDrive.exe
Load configuration
Load UI
Initializing
Start schedule
Log in
Could not log on, please check username and password.
Argument cannot be null.
Parameter name: requestUri
Done press any key to continue

wrote Aug 21, 2011 at 9:01 AM

pamplina wrote Feb 6, 2012 at 9:13 AM

I have the same issue with beta 0.3 and mono-2.10.8-1. I tried with a @hotmail.com account and still didn't work.

wrote Feb 14, 2013 at 8:20 PM